Skip to content


)) Back to the new forum ((

[Resolved] Update links function doesn't work


First thanks for this awesome software, I really love it!
 I recently changed a HDD in my machine so all links to movie are obsolete and need to be updated.
I used the 'Update links' feature but it only worked for few movies, not for all of them.

Can you please help me? I don't see myself changing the link manually for all the movies.

Thank you in advance,


PS: I use Filmotech v3.9.1 (64 bits) on Win 10 Pro.


  • Hi,

    Is there anybody to answer me please?
    Your support is much appreciated,

    Thank you
  • Please,

    I need your help !

    Many Thanks
  • FilmotechFilmotech Administrator
    Hi, sorry for this late answer.

    I don't know why the "Update link" doesn't work for you.

    If you want to change the link manually, you can:
    - Backup your database (Preferences > Profiles > Backup)
    - Export your database as XML
    - Open the XML file in your text editor and change link as expected
    - Create a new profile in Filmotech (Preferences > Profile, click + on the bottom of the list). You need to create a new profile because importing data add movies to the existing database
    - Import your modified XML file
    - If everything is ok, you can delete your old profile

    If something goes wrong, you can restore your previous database
  • tOm48tOm48 Member
    edited March 2022
    Hi, no worries,

    Thank you for the answer, much appreciated.
    This is very strange: I have 3 different profiles.
    I followed the steps you mention, and it worked well for 2 profiles, but not for the 3rd one (the biggest): it ends up with the error: "the file xxxxxxxxx.XML is not a valid XML file" (or something similar, I didn't pay attention very closely).

    So I thought it was a formatting issue due to the fact that I edited the XML file to modify the movies path.
    So I did the following test:
    _ I imported back the original database (I had a backup)
    _ I exported it as XML
    _ I re-imported it straight away: it failed with the same error ("invalid XML file")

    So it looks like for some reason there's an issue with the XML export process for that particular profile.

    But anyway, it's not a big deal: when I want to watch a movie, I edit it inside Filmotech and change manually the drive letter, done.
    Of course, I'd prefer to bulk fix the issue for obvious convenience, but I noticed something else: the XML export format doesn't seem to handle the "already seen" parameter. So eventhough the process was working, I'd loose all the "already seen" information which is pretty annoying.

    Thanks again for the help  :)

  • FilmotechFilmotech Administrator
    There is probably a problem with some special characters :(
    Can you send me your XML file ?

  • tOm48tOm48 Member
    Filmotech said:
    There is probably a problem with some special characters :(
    Can you send me your XML file ?

    Sorry for late reply, I don't receive notifications for new messages, this is why.
  • tOm48tOm48 Member
    I just sent you my XML file.
  • FilmotechFilmotech Administrator
    Ok, there is a problem with "Le Voyageur - 10 Episodes", there is a special character at the end of the synopsis (after "mystérieux auto-stoppeur."). Remove it and try to export the XML again.

    PS : Your database is in french, do you know there's a french forum, and that I'm a french dev ? ;) 
  • tOm48tOm48 Member
    Hi again,

    I found the issue finally: for some movies I've entered the link to the movie file on the "Web page (URL)" instead of "File", this is why these entries didn't get renamed!

    Ah oui merci pour le lien vers le forum francais, la prochaine fois je posterai la-bas !  :)

    Merci encore pour l'aide !
This discussion has been closed.

© 2004-2023 Pascal PLUCHON

Back to the new forum

© 2004-2023 Pascal PLUCHON

Back to the new forum